Fiesta Faction - Ford Fiesta Forums

Please help support Fiesta Faction by clicking this banner!

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Mar 2011
    Location
    Houston, TX
    Posts
    10

    Default Ticking sound right after turning my car off?

    Does anyone else hear a ticking or ratcheting sound coming from the engine compartment when turning the car off? When I turn my car off and get out of the car, I hear this ticking sound that lasts for only about 5 seconds or so, and it seems quite loud. I知 thinking that it may be it may be the computer or perhaps the traction control unit or the power steering unit shutting down. But then again, I知 no mechanic or electrician to know what it really is. Anyone know what it may be?

  2. #2
    Join Date
    Sep 2010
    Location
    Anaheim, CA
    Posts
    3,394

    Default

    Quote Originally Posted by jchrisjackson View Post
    Does anyone else hear a ticking or ratcheting sound coming from the engine compartment when turning the car off? When I turn my car off and get out of the car, I hear this ticking sound that lasts for only about 5 seconds or so, and it seems quite loud. I知 thinking that it may be it may be the computer or perhaps the traction control unit or the power steering unit shutting down. But then again, I知 no mechanic or electrician to know what it really is. Anyone know what it may be?
    Is it a metallic ticking? That's normal for any car, usually it's a heat shield or some other part cooling down, nothing to worry about.
    http://www.socalfiestas.com

    Ford Fiesta: The party comes standard!

  3. #3
    Join Date
    Mar 2011
    Posts
    22

    Default

    Quote Originally Posted by dirtyblueshirt View Post
    Is it a metallic ticking? That's normal for any car, usually it's a heat shield or some other part cooling down, nothing to worry about.
    Both of our Fiestas make the same noise right after the engine is shut off. It is a very rhythmic sound that is there every time without fail. I am not certain what it is yet, but I am sure it is harmless.

  4. #4
    Join Date
    Oct 2010
    Location
    Grand Rapids, MI
    Posts
    172

    Default

    I have it too. Had it since the day I bought it. Not worried a bit. Sounds very intentional.
    2011 Fiesta SES -Yellow Blaze-
    Codename: "Yellow Jacket"

  5. #5
    Join Date
    Mar 2011
    Location
    Weldon Spring, MO
    Posts
    39

    Default

    Mine does it consistantly, too. I think its related to emissions or fuel system sounds like a solenoid firing several times, so its normal.
    LimeSq SES Hatch, Boomerang Spoiler, 6" Billet Ant, ContiExtreme DW's on 17" MSW Type 21 wheels

  6. #6
    Join Date
    Feb 2011
    Posts
    54

    Default

    From the owner's manual:

    "Note: The automatic transmission performs a series of automated checks
    when the ignition is turned to the off position. A slight clicking sound
    may be heard and is considered a normal part of operation."
    2011 SEL PowerShift | Armrest | Leather Shift Knob | Painted Door Release Handles | DRLs

  7. #7
    Join Date
    Oct 2010
    Location
    Grand Rapids, MI
    Posts
    172

    Default

    Quote Originally Posted by Sedan View Post
    From the owner's manual:

    "Note: The automatic transmission performs a series of automated checks
    when the ignition is turned to the off position. A slight clicking sound
    may be heard and is considered a normal part of operation."
    Done. Wonderful.
    2011 Fiesta SES -Yellow Blaze-
    Codename: "Yellow Jacket"

  8. #8
    Join Date
    Feb 2011
    Posts
    129

    Default

    Mine is a manual trans and it does it too. I don't know what it is but it sounds normal.

    My fiesta also makes a "thunk" that seems to come from the transaxle at around 10 mph. Only does it after the vehicle has been turned off and when it initially reaches 10 mph. This also seems normal. I had a tundra that did the same thing.

    -Popups forced me to pay for Tapatalk.

  9. #9
    Join Date
    Mar 2011
    Posts
    23

    Default

    Just heard this on mine for the first time today... installed new plug wires and then when i turned it on and off to test i heard it.. dont know if its related. Friend has the exact same car (manual fiesta s) and his doesnt do it. Any body have answers for the manual?

  10. #10
    Join Date
    Aug 2010
    Location
    Nashville, TN
    Posts
    36

    Default

    Quote Originally Posted by l1v1d View Post
    Just heard this on mine for the first time today... installed new plug wires and then when i turned it on and off to test i heard it.. dont know if its related. Friend has the exact same car (manual fiesta s) and his doesnt do it. Any body have answers for the manual?


    I have a manual SE and it has done it since day one. Im at 15k miles and counting with no issues. I'd say it's normal.
    - 2011 Ford Fiesta SE Tuxedo Black

    - 1989 Ford Mustang GT

    - 2004 Ford Ranger Tremor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •