FiST won't start - no response from button
Fiesta Faction - Ford Fiesta Forums
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2011
    Location
    28 miles from downtown Chicago, pick your direction...and don't choose East!
    Posts
    559

    Default FiST won't start - no response from button

    Posted over on FiestaSTForum last Thursday when this happened, figure a cross-post here can't hurt.

    Quote Originally Posted by brbauer2 Thu Jan 5
    Just went out to get some lunch and the dang think won't start.

    The radio comes on if I hit the power button on the radio, that's about all I can do.

    Keys do not lock/unlock, nothing.

    Power button won't go into Accessory/On mode, pressing the clutch does nothing, can't even get a response when placing the key against the steering column.

    Vehicle has started and ran fine since I got it, and had no issues this morning.

    Anything else I can try before Roadside gets here to take it in?
    Roadside got to the house quickly and got the car to the dealer. They didn't get to look at it until Friday.

    Still no word on what is wrong with it. They seem to be trying to pin anything they can on the fact I have load resistors for my LED turn signals, an add-a-fuse for my dash cam, or the add-a-fuse for my dimming mirror.

    Resistors are obviously tapped into the turn signal circuit. The dash cam is split off from the windshield wiper circuit (F11) in the glove box, and the mirror is split off from the heated seat circuit (F17) in the glove box.

    All 3 mods are ones that I ran on my previous Fiesta's with no issues and have been on the FiST for over a month+.
    '16 Molten Orange ST 2Nov16 –
    '14 Ruby Red SE 14Feb14 – 2Nov16
    '12 Red Candy SE 23Nov11 – 14Feb14

  2. #2
    Join Date
    Nov 2011
    Location
    28 miles from downtown Chicago, pick your direction...and don't choose East!
    Posts
    559

    Default

    Just spoke with the dealer. They are still having trouble talking to any of the computer modules on the vehicle and are waiting on a new BCM to get in. I was told it should be in late today and they will start further diagnosis tomorrow morning.


    I just want my car back...
    '16 Molten Orange ST 2Nov16 –
    '14 Ruby Red SE 14Feb14 – 2Nov16
    '12 Red Candy SE 23Nov11 – 14Feb14

  3. #3
    Join Date
    Nov 2011
    Location
    28 miles from downtown Chicago, pick your direction...and don't choose East!
    Posts
    559

    Default

    BCM got replaced yesterday and they are now able to talk to 3 of 7 computer modules. Have to go through diagnosing/replacing each one one at a time.
    '16 Molten Orange ST 2Nov16 –
    '14 Ruby Red SE 14Feb14 – 2Nov16
    '12 Red Candy SE 23Nov11 – 14Feb14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •