Fiesta Faction banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok we all read about the faulty 2011 fuse box and how everything corrodes. Yes there was a TB and that ended 11/2018. I cannot trust mine any longer lights are gone heated seats work when they want and horn goes in and out . I’m taking the plunge and ordered an entire engine harness this week about $400 delivered
I cannot seem to find even in my factory manual what’s involved in replacing .
there is a video from a guy in Canada on YT
But not really helpful “it takes a day” is all he says . Who here has done this and can give some pointers my concern is can all needed to get through firewall be done “easily “
Is ABS module in the way at all? What are some other things that got in the way that you didn’t foresee having to deal with ?
Other concern is connecting to PCM or BCM
Don’t want to upset the apple cart too much but ………as I said too far gone over 259K on mine!
Also what steps did you take to seal new one prior to install? Was thinking RTV or some version flex seal? Open to suggestions.Tips
Oh yeah they use salt here in Indiana and states next door
Thanks
HoosierFiesta
 

·
Registered
Joined
·
64 Posts
Haven't done one but my advise to you is take tons of pictures.Good luck. Thankfully I caught mine before it was really corroded. I cleaned every fuse, relay and contacts as best I could. reassembled and sprayed it with known. Three years later and still looked perfect when I sold it.
 
1 - 2 of 2 Posts
Top