Fiesta Faction banner

1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My daughter has a 2015 SE (I have a Fusion, my entire family are Ford owners!). The low beam stopped working. Like most of us these days, I Googled it, but what I discovered scares the life out of me! Personally I would have said that this was a serious safety issue, perhaps you are driving on a badly lit highway late at night and rounding a curve and wham, your lights go out! My daughter is a relatively new driver, she could easily panic and before you know where you are, she is off the highway down an embankment and heading for trees! okay, a little extreme but in addition to that, when I tried to figure out the problem I 'wiggled' the relay and... smoke!! Err, what is that old saying about no smoke without...
So, having found out that Ford issued a recall in Canada for this, notably because in Canada they use salt on the roads in winter, err? We live in Michigan, don't talk to me about salt on the roads! And the US; nothing going!!! So, Ford want around $1,000 to fix this, am I missing something? The car is worth marginally more than that!
So, any lawyers that read these sort of posts, start taking names, this has all of the makings of a class action in my opinion.
That aside, I can't let my daughter drive a car like that, so I undertake to fix this issue one way or another. Well, ~$20 later they work (well, 4 hours effort as well!).
So my real question is; how many people have experienced this and for those of you that have a similar design on your fuse box, brace yourself; you probably will! (it is 100% a design flaw on Ford's part if you really look into the placement, protection and potential for issues - the 3 p's that all newer electrical designs seem to ignore!)
 
1 - 1 of 1 Posts
Top