Fiesta Faction banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone, I have a 2016 fiesta. I left my dashcam on and it drained the battery. After jumping it, it starts fine but displays a message saying “transmission malfunction: service now” and appears to be in limp mode as it won’t go very fast and revs high. I have unplugged the battery to try and reset the computer but the message continues to be displayed. I read that when the battery dies it could damage the TCM and it would need to be replaced. I also read it may be under a manufactures extended warranty. However the build date for my car is 03/2016 which didn’t fall within the extended warranty coverage I saw on some articles. Hoping to get some advice on how to go about fixing this?
 

·
Registered
Joined
·
18 Posts
Does your instrument cluster show any warning lights? It happened to a 2011 I owned a few years ago when I was jump starting another car using my Fiesta's battery.
If I recall the ABS, ESP and Hill Start assist lights showed up and the fix was indeed to replace the TCM.
My Fiesta was shifting OK but the ABS was not working and the car would roll backwards if the brake pedal was released (like on a manual transmission).

If you don't have any warning lights, try replacing to a new battery first and see if that fixes your issue. It happened to a Focus my parents owned a few years ago and would show a Transmission malfunction message anytime the battery was about to die.

Enviado desde mi SM-G991U1 mediante Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply, the check engine light and a little orange wrench are the only lights on. Along with a little red i in a box next to the center console screen area
 

·
Registered
Joined
·
18 Posts
Thanks for the reply, the check engine light and a little orange wrench are the only lights on. Along with a little red i in a box next to the center console screen area
Wrench light is "Service", it has nothing to do with the transmission malfunction. Maybe you have an oil change due or the service interval was not reset on the last oil change.
About the CEL it could be anything, take it to an o reillys or Autozone for a free scan when you get a new battery.
The i in the middle of the screen means you've got a warning message on the center display which is likely the "transmission issue" message you saw earlier on.

Enviado desde mi SM-G991U1 mediante Tapatalk
 

·
Registered
Joined
·
10 Posts
HI, I have a 2013 Ford Fiesta. About 4 years ago, I left the lights on to go into a store for a very brief time. When I came out, the car was dead. My son came and jumped the car and I had to drive home which was about 3 blocks away. I felt as though I had no brakes but I got home ok. Next day I wanted to take it to the dealership to get a new battery if need be. I started driving down my street and had to turn around, go home and actually have the car towed to the dealership which is only about 3 miles away. I couldn't even make it that far safely. The transmission control module had to be replaced which at the time was no charge. Apparently, there is some connection between the battery and the computer systems in the car. It was a very scary experience for me. Ford changed the battery and everything is fine so far. Looks like if you jump the car or do anything with the battery yourself, it upsets the computer which is not good.
 
1 - 5 of 5 Posts
Top