Fiesta Faction banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Car started this little fun trick where it stalls, typically when coming from a stop and accelerating. It bucks a little and dies. Put car in park, turn call all the off then restart and its fine. Has yet to happen in 3rd or above, possibly 2nd gear.

Yay

Took to my mechanic who said its the TCM, since we all know what hot garbage of the autos in these are so it seemed plausible. Dropped off at Ford dealer and after 4 days they said they have confirmed its a vac leak (didn't say which code) and NOT a tranny issue and that they were searching for it. Now its been there 10 days and....nothing.

So anyone have something like this? I'm sure they don't want t a mook like me making suggestions but after 10 days I feel like a vac leak shouldn't be too hard to find. But what do I know.

Not sure my next move other than I want it fixed so in the next few months I can dump it try to forget I even owned it
 

·
Super Moderator
Joined
·
1,316 Posts
Have you heard back from the dealer?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
UPDATE::::

Car at the dealer another week. They replaced a gasket (didn't specify which but it was in bad condition) when they were replacing the purge canister valve. Took it for a drive and still stalls. They say they are getting a code pointing to an evap issue but I don't know the code. Seems like amateur hour over there. The car is worth like $11 but I've put $2k into it since the beginning of the year. This thing will never make it to 100k miles. Once fixed it will be traded ASAP.

I feel like getting it back from the dealer but unsure what to do with it. Its only there because the previous mechanic said it was a TCM issue which Ford says its not.
 
1 - 4 of 4 Posts
Top