Fiesta Faction banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hi ,just running this by any guys had same , 2016 ecoboost , 14000 miles , lost power , but only after 15 to 20 mins driving , had three scanners on it , 2 garages , no 2 injector replaced , all coils replaced with new plugs , auto electrician says not wiring as fault would be there all time. he says pointing to ecu? losing faith now £500 pounds so far and back to square one .before i remove ecu for testing anyone else any thoughts?wiring has been checked for brakes or loose wires .also if ecu at fault and repaired does it have to be reprogramed again .or if i got a used ecu with exact model numbers does that have to be reprog, . thxs in advance , pulling hair out now , 14000 miles ,been going on now for 6 weeks .
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Now sent ecu , to ecu testing.com. They can't get into it ? Any ideas where I can get ecu tested ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Will look but both garages went over most , but might have missed , have now found ecu company that will transfer my circuits from old ecu to new carcass ecu after testing ,so will see if works , as inners of my ecu it will not need reprogramming. Hope they find something , technician said losing power after car has warmed up is a common ecu fault , if not another 175 pounds down drain . Only getting it repaired to sell now as wife wants rid of it lol
 

·
Super Moderator
Joined
·
1,287 Posts
hi ,just running this by any guys had same , 2016 ecoboost , 14000 miles , lost power , but only after 15 to 20 mins driving , had three scanners on it , 2 garages , no 2 injector replaced , all coils replaced with new plugs , auto electrician says not wiring as fault would be there all time. he says pointing to ecu? losing faith now £500 pounds so far and back to square one .before i remove ecu for testing anyone else any thoughts?wiring has been checked for brakes or loose wires .also if ecu at fault and repaired does it have to be reprogramed again .or if i got a used ecu with exact model numbers does that have to be reprog, . thxs in advance , pulling hair out now , 14000 miles ,been going on now for 6 weeks .
We are lacking details on the issue. Is this loss of power repeatable? Is there loss of boost? Any codes? Why where those parts replaced? Need to be methodical in troubleshooting


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
I have been having a missfire at idle.. but only when it's hot, spark plugs were due so I replaced them but no change then a couple of times when starting up cold it was sounding like it was running on 3 cylinders. I ran the fuel till almost completely empty and got half a tank at a different service station and seems to be gone completely so far. I got the 2014 FiST 1.6L ecoboost with just over 96,000 kilometers on the clock. Must have been some bad fuel.. hopefully that's all it was.

Forgot to mention I been running the car on 98 unleaded from the day I bought it brand new.

Sent from my Mi MIX 2S using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Parts were changed because garages said that's what they probably thought it was , car is fine on start up , but between 10 to 20 minutes it lose power , if you drive it hard fault code will come up sometimes , garage had it four days before they could get code up it said no 2 injector which was replaced.then it run ok for 2 weeks , then back to bad again,so they changed all coils and plugs , spoke to ecu company they said there biggest clues for ecu fault was lose of power after warm up?now sent ecu to company but as you know ecoboost ecu cannot be tested ,so my ecu info is being transferred to reconditioned unit with my cars info so plug n play I hope .
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Ecu now being exchanged , as can't be tested , information is being transferred to another unit , so no reprogramming to car as its same info . Should get back Tuesday so will update as to progress hopefully fault cured !! If not , for sale lol
 

·
Registered
Joined
·
13 Posts
What thread can I ask about my 1.6L ecoboost fiesta? I just started it now and it was definitely running on only 3 cylinders.. what amount of kilometers (about) would the coil packs start playing up..??

Sent from my Mi MIX 2S using Tapatalk
 
1 - 11 of 11 Posts
Top