Fiesta Faction banner
1 - 17 of 17 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
2013 Fiesta SE Powershift Automatic

I am randomly getting Engine malfunction, service now. I have run the codes using an OBD II reader and find nothing. I have also tried this while the message is being displayed. I have also run the vehicle health report while the message is being displayed. I can never get a code or any kind of clue as to what the problem is!!!!

The main frustration with this is that when it happens on the interstate I lose cruise control. If it happens at idle you hear the idle change for a split second and it seems to drive normally otherwise. Turning it off and back on clears the message.

What the heck is going on with this thing? I just bought it!!!

EDIT: Car is at 41,000 miles.
 

·
Registered
Joined
·
5,672 Posts
I am throwing in my thought. Since you mention cruise control AND the idle change, I would suspect a vacuum leak somewhere or an electrical issue with the TB. Others will chime in, welcome to the Faction if I missed you earlier :eek:
 

·
Registered
Joined
·
74 Posts
Check either this TSB:
TSB 13-3-19
Or this one that replaces it I think:
TSB 13-11-15

It really looks like what I had and that's what they did to my car. The difference is you're saying that other than losing cruise control and idle moving, you have nothing wrong, well for me the gas pedal was not reacting for 1-2 seconds every time I was letting go.

At 41,000 miles you are probably out of warranty? I don't remember how long it took (it happened two years ago) for them to fix it, but some are saying 1.5 to 2 hours. Since it's a known issue, maybe they will do it under warranty, maybe? It's worth a try, but don't expect much.
 

·
Registered
Joined
·
4,187 Posts
A problem with the throttle position sensor (TPS) can also do this. I had it happen on my prior '12 and it was a b**ch to have happen when the dealer was open. If it happens AND you can get to a dealer, leave the car running so they can check stuff. Any code (if thrown) will not log so shutting off the car will clear the problem.
 

·
Registered
Joined
·
1,165 Posts
With the cost of flash memory, why don't they log every code and recycle the oldest code. I bet you could get hundreds of thousands of codes stored and a cheap 1 gig SD card with date and time. Expand that to flash frames when the code happened and use a 4GB card to store thousands of codes and data. At least then we would have a log of issues to bring to the dealer.

Of course if that happened, then the manufacturer would end up paying for more repairs because the codes would never magically vanish like they do with a lot of newer cars.
 

·
Registered
Joined
·
1,967 Posts
2013 Fiesta SE Powershift Automatic

I am randomly getting Engine malfunction, service now. I have run the codes using an OBD II reader and find nothing. I have also tried this while the message is being displayed. I have also run the vehicle health report while the message is being displayed. I can never get a code or any kind of clue as to what the problem is!!!!

The main frustration with this is that when it happens on the interstate I lose cruise control. If it happens at idle you hear the idle change for a split second and it seems to drive normally otherwise. Turning it off and back on clears the message.

What the heck is going on with this thing? I just bought it!!!

EDIT: Car is at 41,000 miles.
Hi m4ick,

I see you mentioned in another post that you were calling your dealer. Were you able to get an appointment set up? Please let me know, along with your mileage, and I'll check out some options.

Meagan
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #7 ·
Hi m4ick,

I see you mentioned in another post that you were calling your dealer. Were you able to get an appointment set up? Please let me know, along with your mileage, and I'll check out some options.

Meagan
Hi Meagan,

Thanks for the reply. I have called the dealer and found that they could do the reflash recall for the TCM on a Saturday but I have had family things to take care of (having to drive to my home town 3 hours away every weekend) so I haven't had time to set an appointment yet, I will likely take a day off to visit the dealer and go through everything with them. It would be nice to sort out all issues at once as I just bought it but I have to put in for a day off 2 weeks in advance.

The car is at just over 41,000 miles and drives great, minor clicks and clunks from the transmission but I believe it is normal for the Powershift. The only irritating thing so far is losing cruise control in the middle of my trip!

What options are you referring to?
 

·
Registered
Joined
·
1,967 Posts
Hi Meagan,

Thanks for the reply. I have called the dealer and found that they could do the reflash recall for the TCM on a Saturday but I have had family things to take care of (having to drive to my home town 3 hours away every weekend) so I haven't had time to set an appointment yet, I will likely take a day off to visit the dealer and go through everything with them. It would be nice to sort out all issues at once as I just bought it but I have to put in for a day off 2 weeks in advance.

The car is at just over 41,000 miles and drives great, minor clicks and clunks from the transmission but I believe it is normal for the Powershift. The only irritating thing so far is losing cruise control in the middle of my trip!

What options are you referring to?
I'm sorry about the delay, I never saw you had replied. Were you able to get to your dealer to have this taken care of?

Meagan
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #9 ·
Not yet, I put in for taking the 28th off work so that I can have time to spend at the dealer. I will be scheduling an appointment for that day at some point tomorrow.
 

·
Registered
Joined
·
1,967 Posts
Not yet, I put in for taking the 28th off work so that I can have time to spend at the dealer. I will be scheduling an appointment for that day at some point tomorrow.
Sounds like a plan. Once you do, please private message me your VIN, updated mileage, best daytime phone number, full name, and dealer name/location. I'll take a closer look.

Meagan
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #11 ·
PM sent. Also, thank you for your input Cobra348 and KalterBlut. Sorry I didn't give you a shout out earlier!
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #12 ·
Meagan, am I expecting a reply?
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #13 ·
I confirmed this is the throttle position/pedal position issue with a friend's VCMII, is this covered under the emissions warranty or any warranty, I'm over 36,000 miles.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #14 ·
I found it, it appears this is covered under emmisions defect warranty.
 

·
Registered
Joined
·
2 Posts
I have problems with my Ford Fiesta 2010. TD version (manual shift). While driving, suddenly car starts to "cough" while every time it drops acceleration, oil and battery lights light for a split second. Afterwards I get "Engine malfunction. Service now" message. And my gas pedal don't work at all (I put my foot on it, nothing - it wont accelerate) and I have to stop on the side of the road (and it regullary happens when I take my kid from kindergarden :(().

Car was sent to couple of auto electric shops (not official one yet though). With no luck. Battery changed and some other things (have to ask previous owner which things) but no luck. Car was fine for a month (I bought it few months back - previous owner is someone from my family so I was familiar with the fault the car has).

My question is do you have any idea what is wrong? Could it be TSB 13-3-19 or TSB 13-11-15 ? From my understanding, these two things are some wiring issues and can be fixed with some rewiring or similar. What I am afraid of is that at my Ford official service shop they don't have an idea about those two things . And if it is the coomon problem for Ford Fiestas, why Ford is not resolving these things for free, since its production error of sorts (if I understood correctly).

FordService, I read some of your posts on this site and you seem like a good person wiling to help. Any insight of yours is welcome. Thanks in advance.

Update: happened this morning again. I had Carly OBD2 reader, plugged it in and successfully made connection with Carly android app. To my suprise, app didnt get any code!! I run the health scan twice while "Engine malfunction. Service now" error was displayed, no error whatsoever. Quite strange, was hoping to get some code that I can share with official Ford service.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #16 ·
I have problems with my Ford Fiesta 2010. TD version (manual shift). While driving, suddenly car starts to "cough" while every time it drops acceleration, oil and battery lights light for a split second. Afterwards I get "Engine malfunction. Service now" message. And my gas pedal don't work at all (I put my foot on it, nothing - it wont accelerate) and I have to stop on the side of the road (and it regullary happens when I take my kid from kindergarden :(().

Car was sent to couple of auto electric shops (not official one yet though). With no luck. Battery changed and some other things (have to ask previous owner which things) but no luck. Car was fine for a month (I bought it few months back - previous owner is someone from my family so I was familiar with the fault the car has).

My question is do you have any idea what is wrong? Could it be TSB 13-3-19 or TSB 13-11-15 ? From my understanding, these two things are some wiring issues and can be fixed with some rewiring or similar. What I am afraid of is that at my Ford official service shop they don't have an idea about those two things . And if it is the coomon problem for Ford Fiestas, why Ford is not resolving these things for free, since its production error of sorts (if I understood correctly).

FordService, I read some of your posts on this site and you seem like a good person wiling to help. Any insight of yours is welcome. Thanks in advance.

Update: happened this morning again. I had Carly OBD2 reader, plugged it in and successfully made connection with Carly android app. To my suprise, app didnt get any code!! I run the health scan twice while "Engine malfunction. Service now" error was displayed, no error whatsoever. Quite strange, was hoping to get some code that I can share with official Ford service.
There are codes stored, regular code readers will not pull the wrench light codes. An ELM-327 with Forscan on a laptop will, Forscan Lite will as well with a Bluetooth ELM-327. They're like $30 on Amazon, make sure they say they're made for Forscan. The codes associated with the wrench light will point you in the right direction.
 

·
Registered
Joined
·
2 Posts
I bought one, and the error it displays is error P0366 crankshaft sensor. The car mechanics changed this sensor already 3 times. What is strange is that the car is working fine for a month or two after changing this sensor, then it throws this error every week or so periodically. It probably has to do with some sort of oil residue or something that gets the sensor "dirty".. Maybe reluctor ring on crankshaft? I doubt it is the ECU problem, it is the only error that it keeps displaying.
 
1 - 17 of 17 Posts
Top