Fiesta Faction banner
1 - 18 of 18 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Very perplexing problem here. I noticed the ambient lighting on my 2011 Fiesta started flashing and then went off all together. At the same time I noticed the lower IP lights (HVAC & shift bezel) were also out. Furthermore, the rear tailights are also not working! I suspect this is all on one fuse but I have yet to be able to identify a fuse for any of the three systems...Does anybody have any experience with this? Does anyone know what Fuse to check? Any help would be greatly appreciated!

--Matt
2011Fiesta SE
2011 Explorer
2014 Fiesta SE
1999 MustangGT
 

· Registered
Joined
·
2,979 Posts
I would have suspected the interior light fuses would be under/behind the glove box. In case they are not there, you may want to pull the cover off the fuse block under the hood next to the battery and look for corrosion. This is a known issue for the 2011-2012 fiesta.
 

· Registered
Joined
·
1,976 Posts
Very perplexing problem here. I noticed the ambient lighting on my 2011 Fiesta started flashing and then went off all together. At the same time I noticed the lower IP lights (HVAC & shift bezel) were also out. Furthermore, the rear tailights are also not working! I suspect this is all on one fuse but I have yet to be able to identify a fuse for any of the three systems...Does anybody have any experience with this? Does anyone know what Fuse to check? Any help would be greatly appreciated!

--Matt
2011Fiesta SE
2011 Explorer
2014 Fiesta SE
1999 MustangGT
Welcome, mhstang1999!

I see you mentioned going to the dealer in the other post; were they able to find any solutions or repairs? Please let me know, along with your mileage, and I'll see how to best assist.

Meagan
 

· Registered
Joined
·
2 Posts
Very perplexing problem here. I noticed the ambient lighting on my 2011 Fiesta started flashing and then went off all together. At the same time I noticed the lower IP lights (HVAC & shift bezel) were also out. Furthermore, the rear tailights are also not working! I suspect this is all on one fuse but I have yet to be able to identify a fuse for any of the three systems...Does anybody have any experience with this? Does anyone know what Fuse to check? Any help would be greatly appreciated!

--Matt
2011Fiesta SE
2011 Explorer
2014 Fiesta SE
1999 MustangGT
The same exact thing happened to me. Did you solve this problem? Was it a fuse and if so which one? Ford - can you help?
 

· Registered
Joined
·
3 Posts
I just had this problem creep up today and very thankful I found this post!
I have a 2011 Fiesta SE with 238k miles and have hadissues with shifting and then this failure today. Got home and found my fuse box looking a little fuzzy....
Half of the fuses pulled out in pieces, which was very fun. ?

I HAVE to fix this, But I'm curious if anyone here thinks the dealer may still honor the recall? We never received a recall notice for this, But it's expired in November 2018.
 

Attachments

· Registered
Joined
·
1 Posts
As usual I’m late to the party but maybe this will help someone. I had multiple issues with my 2011 Fiesta and I mean some were dire issues including lights going out for no apparent reason. We knew that the little car I loved would have to go to the dealer in another town because of the Service Manager - the Fiesta Whisperer. He had my car for 8 weeks but I told him to take his time, I had another vehicle. And for about $2500 everything worked! But he told me that Fiestas have a bad reputation for their fuse boxes becoming corroded. Well that’s just marvelous. He said it’s something I’ll have to keep an eye on but I’ll just turn around and go back to Spenser. I don’t want to break a nail.
 

· Registered
Joined
·
1 Posts
MANY THANKS to all above you have just saved my 2010 Fiesta. Just about to phone the breakers as all the rear lights not working and spent hours trying to fix and thought just not viable to go any further and stumbled on these posts and pulled F22 and it broke up as i pulled it out and 50p later heypresto all working fine again. What did we all do before these forum sites!!!!
 

· Registered
Joined
·
86 Posts
When I worked on my/daughters Fiesta I read about the fuse box horror. I took every fuse out one by one and made sure the connections were clean. Then I sprayed the whole fuse box with a non conductive anti corrosion spray. The air vent that is part of the cover I filled with foam to keep dust out. Looked at it every so often and it never changed after the clean up.
 

· Registered
Joined
·
1 Posts
hi. so im new here. i too, have a problem. yestereday , my 2011 ford fiesta se that works perfectly and never had a problem since 2012 suddenly went dead with ambiant lighting ( colors) and read brakes. i did change the fuse in the motor ( the blue 15 a f22) as when i pulled the old out, it was broken and all nasty. i did put electrical spray to wash the hole where the fuze goes. but it did not resolve. if im reviving this thread and someone could help me find another solution, i would be grateful :). im anxious this will cost me so much , i dont have money, im not working now. thanks x 10000
 
1 - 18 of 18 Posts
Top