Fiesta Faction banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2012 Fiesta SE with the dual clutch transmission. Can't seem to fix the issue with the code P07A3 Transmission Friction Element A Stuck On. Symptoms were stuttering, bucking, hesitation. Been to the dealer three times. Replaced clutch assembly and seals, then the transmission control module TCM and reflashed, then the clutch actuator motors. It has good grounding. Code still shows up and now it drives good about half the time and skips 3rd and 5th the rest of the time. Does this nearly every other start. Now I'm wondering if it may be a bad sensor or still the TCM. Any thoughts?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Finally got this fixed. The problem was the clutch actuator lever A was damaged enough that the TCM couldn't quite determine if it was a problem, so it let it work half the time. The actuator levers and sleeve behind the clutch weren't replaced when the clutch was done before and they didn't ask me if I wanted it done then. Now they wanted to charge me $1650 to do it. I complained to the service manager so now it's just $150 to pull it apart again and change those parts. So it pays understand the problem a little, speak up when necessary, and replace all the wear parts if they pull the transmission.
 

·
Registered
Joined
·
1 Posts
Finally got this fixed. The problem was the clutch actuator lever A was damaged enough that the TCM couldn't quite determine if it was a problem, so it let it work half the time. The actuator levers and sleeve behind the clutch weren't replaced when the clutch was done before and they didn't ask me if I wanted it done then. Now they wanted to charge me $1650 to do it. I complained to the service manager so now it's just $150 to pull it apart again and change those parts. So it pays understand the problem a little, speak up when necessary, and replace all the wear parts if they pull the transmission.
Made an account to say thanks. Saved me heaps on diagnosing my issue. Thank you Wolverine
 
1 - 3 of 3 Posts
Top