Fiesta Faction banner

1 - 6 of 6 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter #1 (Edited)
Of course I've seen the good old "poping noise" thread. Not sure what the pope has to do with the radio or what noises he makes at night. I've yet to see a fix for the factory unit, just a lot of replacements.

I've found a few people on the interwebs claiming that the IC 70886FB is the issue and that a good cross reference replacement part is TDA3681J. Well after having removed the radio momentarily and reseating plugs, I reinstalled it the problem magically went away for a week or two. When the problem came back a good slap would either make it work again, quit completely, or maybe even go from static to squealing! Kinda useful if you don't know what to eat. Slap it, if it shuts off pizza, if it makes static Chinese, if it squeals Mexican it is!

So I removed it again and brought it in, took it apart looking for evidence of heat damage or bad solder joints, even looked at the joints on the ICs using the case as a heat sink. Couldn't see anything major but I don't have a proper microscope. Re-installed it and guess what, it's working again! A few minutes of listening and POP, it's off.

THIS BEHAVIOR JUST SCREAMS BAD SOLDER JOINT

Come to find out that 70886FB runs pretty hot and could potentially wear out some of the solder joints over time. So I just removed the radio again, opened it up and removed the board, re-soldered every pin on that IC and also took a few moments to re-solder 3 of the largest capacitors on the board since those would be the most vulnerable to vibration. Added some fresh thermal compound and back together it went.

I re-installed it and its been working for the last day. I'm going to do my best to follow up here in a month so feel free to reply to this thread in a month or so remind me to follow up. I'll certainly swallow my pride and tell you if it wasn't so you don't waste your time. But I'll probably proceed to pull it apart and solder more joints if that's the case. I want to see a fix for this garbage made public.
 

·
Registered
Joined
·
4 Posts
I have similar issues on my '11. I've learned that the wiring bundle from the control panel to the display screen is wonky. I had the cover off and could make the display go on and off by wiggling the wires. Now, when it goes out, I smack the cover and can get it to come back.
 

·
Registered
Joined
·
4 Posts
I also had issues with the power/ volume knob being jammed (too many CPR attempts to bring the radio back on...) i replaced the panel with a JY one and have been ok. I occasionally notice the backlighting goes out at night and the display goes back to daytime brightness, but at least it works!
 

·
Registered
Joined
·
39 Posts
My car has the loud popping and squealing sound even with they key out! It doesn’t stop until the car powers off a few moments after turning the car off and taking out the key.

Keep the posts coming until we get a fix!

Thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
39 Posts
Radio problems seemed to have resolved themselves.
First the radio went completely out after I pounded on the dash like a mad man. Now it came back on its own and will stay on for hours of driving.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top