Fiesta Faction banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2016 Ford Fiesta S / 103,747 miles / Manual transmission / No error codes.

For the past couple of weeks my car has been idling strange. Usually, after I start the engine the idle increases to around 1200 rpm and then settles to around 900-1000 rpm after about 15 seconds. Now after I start the engine, the idle increases to 1200 rpm but then immediately drops to around 900 rpm then back up to 1200 rpm continually up and down. It feels "rougher" than usual and sounds like it might stall out if the rpm drops any more. Also, the exhaust smells more pungent/rich than usual but the fumes are clear/ no smoking. Any ideas? Thanks.
 

·
Registered
Joined
·
32 Posts
Did you solve? I have exhaust smell at cold start only and slight stumble at throttle tip it with a bit of valve rattle randomly. I cleaned fuel vapor purge valve and I think helped a bit but will likely change with new. Did you try this yet?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 · (Edited)
Did you solve? I have exhaust smell at cold start only and slight stumble at throttle tip it with a bit of valve rattle randomly. I cleaned fuel vapor purge valve and I think helped a bit but will likely change with new. Did you try this yet?
Yes, it ended up being an issue with my throttle body. I don't remember the code but when I got the solid engine light alarm I took it to AutoZone and used their OBD scanner on it. The print out suggested replacing my throttle body, which I did, and afterwards the surging issue was resolved and the alarm light cleared.
 
1 - 3 of 3 Posts
Top